Unable to Connect to Windows 2008 server using remote desktop when RDP 7.0 (6.1.7600.16385) is installed on Windows XP SP3
Issue
When you try to connect to a Windows 2008 or Windows 2008 R2 server from the Internet from a client running Windows XP Service Pack 3 you are unable to connect. Clients running Windows 7 and Windows Vista are able to connect without any issue as are Windows XP Service Pack 2 clients.
Furthermore if you configure the Connect From Anywhere options in the advance section and set the Logon Method to Ask for password (NTLM) you are able to connect but rather than being automatically logged into the server you are presented with the Windows 2008 logon screen and have to enter your password again.
This affects clients that are connecting to servers and RemoteApp using Terminal Server Gateway or Remote Desktop Gateway servers.
Cause
This problem is caused when version 7.0 of the remote desktop client is installed
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=72158b4e-b527-45e4-af24-d02938a95683
this file has an internal version number of 6.1.7600.16385 and is often confused with RDP 6.1 which has a version number of 6.0.6001.1800
Resolution
To resolve this issue you need to remove RDP 7.0 from your computer to do this use the following steps:
1.
Log into the computer as an administrator.
2.
Open Add/Remove programs.
3.
Find the update Hotfix for Windows XP KB969084 and remove it from the system
When the update has been removed the version of MSTSC.EXE that shipped with Windows XP SP3 will be restored. This can be confirmed by browsing to C:\Windows\System32 and then viewing the properties of MSTSC.EXE. The File version should read 6.0.6001.1800. If the version is shown as anything different you can download the RDP 6.1 (KB952155) client here
http://www.microsoft.com/downloads/details.aspx?FamilyID=6e1ec93d-bdbd-4983-92f7-479e088570ad&DisplayLang=en
http://www.yourofficeanywhere.co.uk/
http://www.cardium.co.uk/